PROBLEM! Turnigy Mobius 2-Achs Gimbal mit Tarot Controller

    • PROBLEM! Turnigy Mobius 2-Achs Gimbal mit Tarot Controller

      Hallo,

      ich habe ein Problem mit dem Hobbyking "Turnigy Mobius 2-Axis Gimbal with Tarot Controller" (Produkt ID: 9171000509-0).

      Das Gimbal habe ich laut Anleitung gebaut. Ich habe es unter meine Phantom montiert.

      Beim ersten mal mit Strom versorgen (Lipo 3S), zum ausprobieren, ist es wild durcheinander in alle Richtung drehend rum gezappelt.
      Ich hatte noch keine Kamera in den Gimbal gebaut!
      Ich habe den Stromstecker darauf hin wieder gezogen! Es ist noch nicht an die Naza angeschlossen, ich wollte nur mal die Funktion prüfen.

      Als ich es das zweite mal eingesteckt habe ist nichts mehr passiert!
      Es leuchtet beim einstecken der Stromversorgung 3x die grüne LED und konstant die orange LED. Das Gimbal hängt einfach so rum. Bewegen tut sich nichts mehr!

      Was soll ich machen? Finde im ganzen Netz keine Anleitung.
      Über jede Hilfe wäre ich sehr froh.

      Viele Grüße
      Gerd
    • Erstmal herzlich willkommen hier im Forum. Ich habe auch ein tarotgimbal. ich schaue mir das gleich mal an. Ich weiß es jetzt aus dem Stegreif auch nicht mehr so, was die LEDs zu bedeuten haben. Ich werde gleich mal mein Gimbal anwerfen und berichten.
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • So...ich habs probiert. 3 mal grün ist ok. Die Orangene Leuchtet dann ein paar sekunden länger. In der Zeit darf das Gimbal absolut nicht bewegt werden. Da wird die IMU initialisiert. Ist das erfolgreich abgelaufen, geht die Orangene LED aus und die blaue LED geht an und das Gimbal ist betriebsbereit. Wird in der Zeit das Gimbal minimal bewegt, leuchtet die orrangene LED weiter und der Initialisierungsprozess beginnt von vorne. Also absolute Ruhe muss das Gimbal haben.
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • Mußte das Ding nicht vorher mit ner SW erstmal Grundkalibrieren ? Ich kenn das HK-Ding nicht, hab aber selber ein billiges NoName im Einsatz, und bei dem war´s halt so das erstmal über ne GUI der Sensor kalibriert werden mußte.

      Zumindest verstehe ich auch so die Anmerkung beim Produkt :
      Note: This is a Kit and does require some assembly and a Windows based computer to flash the Tarot configuration with the included USB tool.
      Greez Chris

      [HR][/HR]www.HaDi-RC.de - inventor of P-Ion & HeatBox
    • Hallo,
      erstmal vielen Dank für die wirklich gute Hilfe hier im Forum,und auch an Dich Frank für die Super Hilfe über Facebook.
      Wo andere das Gimbal dort schon als "tot" gesehen haben, hast Du weiter gemacht. Danke.

      Ich bin jetzt wirklich ein großes Stück weiter. Das Gimbal justiert sich, nur die Kamera schaut nach unten. Ich Denke das geht dann über die Software und auch wenn das Gimbal dann an der Naza-M V2 angeschlossen ist.

      Wie kam das alles?
      Naja, ich sag mal: Die Anleitung von Hobbyking ist miserabel.
      Ich bin absoluter Newbie was ein Gimbal angeht.
      Meine Fehler (das wurde alles nicht oder falsch in der HK-Anleitung beschrieben):

      Den Gimbal beim ersten mal einschalten, nur MIT Kamera einschalten und initialisieren lassen.
      Die Kamera ist sozusagen das Gegengewicht.
      Der Gimbal sollte am Kopter hängen und dabei nicht bewegt werden.

      Bild6 in der HK-Anleitung zeigt die IMU mit dem Kabel nach hinten Richtung ROLL-Motor! FALSCH!
      Das Kabel gehört Richtung TILT-Motor.

      Bild7 in der HK-Anleitung zeigt die Anschlüsse für die beiden Motoren. FALSCH!
      Solltet Ihr das Gimbal so aufgebaut haben wie in der Anleitung, das ROLL-Motor Kabel wird nach unten gesteckt, das TILT-Motor Kabel nach oben.

      Noch ein Tipp den ich gelernt habe:
      Sollte das Gimbal anfangen wild zu „zappeln“ wie ein Breakdancer sofort vom Strom trennen.

      Alle Tipp´s sind ohne Gewähr ich übernehme keine Haftung. Bitte probiert es vorsichtig aus!
      Sobald ich mehr weiß, schreibe ich wieder.
      Viele Grüße
      Gerd

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mrgfink ()

    • Ok.Gerd. Ich freue mich, daß es schonmal so weit ok ist. Als Nächstes kommt dann das Setup über die GUI. Ich werde heute Abend mal meine Settings auslesen und hier posten. Allerdings habe ich das richtige Tarotgimbal dann auch für die Gopro. Also die PID-Einstellungen solltest du bei deinem erstmal so lassen. Es geht hier wirklich nur noch um kleine Justagen, Wegbegrenzungen u.s.w. Das kannst du dann eigentlich 1:1 von mir übernehmen.

      Schau dir auch mal diesen Beitrag aus dem Nachbarforum an. Da ist eigentlich alles darüber sehr schön beschrieben:

      Google-Ergebnis für http://fpv-community.de/attachment.php?attachmentid=63289&d=1373807899&thumb=1
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von chuti ()

    • Hallo Frank,
      mittlerweile habe ich auf meinem Rechner auch die Gimbal Software drauf! Die erkennt mal den Gimbal, mal nicht, ist ein Hin- und Her!

      Die Kamera hängt immer noch nach unten.
      Das macht aber der Gimbal. Wenn ich den Copter auf und ab, hoch und runter bewege, schwenkt die Steuerung die Kamera nach unten. Die ROLL-Achse stimmt.
      Der IMU müsste nach den ganzen Anleitungen die ich jetzt gelesen habe auch stimmen.
      Was kann ich da machen?

      Viele Grüße
      Gerd

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mrgfink ()

    • Mit dem Erkennen und mal nicht, ist das so eine Sache. Lass der Software einfach Zeit boote ab und zu mal den Rechner neu und dann klappt das eigentlich. Ich hatte mich damals auch an dem phänomen dumm und dusselig gesucht. Einmal hatte ich das Gimbal angeschlossen und der Rechner hatte es wieder nicht erkannt. Dann ein Telefongespräch und als das beendet war, war alles in Butter.

      Die Kameragrundeinstellung kannst du dann in der GUI einstellen. Ich mach dir dann einen Screenshot, wie alles stehen muss. Aber bitte spiel nicht an den Reglerwerten rum. Ich habe nur die Werte für das Gimbal mit Gopro und es müsste mit dem Teufel zu gehen, wenn diese Werte bei dir passen würden.
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • ja, aber grundsätzlich solltest du zuerst versuchen, die Cam auf dem Träger möglichst so auszurichten das sie bei inaktivem (stromlosen) Gimbal in der Waage steht. Danach erfolgt die Kalibrierung der Sensoren, der Wirkrichtung (damit das Gimbal auch gegensteuert und nicht mitsteuert) sowie das Einstellen der PID-Werte (ausschlaggebend für Stärke der Gegenwirkung, Geschwindigkeit der Gegenwirkung usw. - soll ja auch nix schwingen).

      Normalerweise sollte das Gimbal und somit die Cam dann waagerecht ausgerichtet sein, ich weiß aber auch das es je nach Gehäuseform schonmal vorkommen kann, das die Cam in einem nicht zu ändernden Winkel zur Montageplatte steht - und diesen "Offset" kannst du über die Roll- und Pitchanschlüsse beeinflussen und auch bewußt nutzen, um z.b. im Flug die Cam vom Blick nach vorne mittels eines freien Proportionalgenbers stufenlos bis senkrecht nach unten "schauen" zu lassen.
      Greez Chris

      [HR][/HR]www.HaDi-RC.de - inventor of P-Ion & HeatBox
    • mrgfink schrieb:

      ...verstehe ich Richtig: Mit der GUI kann ich die TILT-Achse so verstellen (einstellen), das die Kamera Horizontal nach vorne schaut?

      Viele Grüße
      Gerd


      Jep, das kannst du. Ich kann dir jetzt noch keinen Screenshot machen. Ich kann das Gimbal noch nicht am Rechner anschliessen. Aber ich habe dir mal von der Gui und dem Controller die original Anleitung hochgeladen. Das kannst du hier runterladen:
      copterlight.de/get_file.php?id=29118567&vnr=930045
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • So.....Zuerstmal zum connecten. Schliesse das Gimbal an den Rechner mit dem speziellen kabel an.

      Schau im Gerätemanager, auf welchem com-port das Gimbal ist.

      Starte die Gui und öffne den entsprechenden com-Port. Das geht unten rechts in der Gui. Ein Screenshot hänge ich mit an.
      Jetzt warte einfach eine weile und sieh zu, daß das Gimbal ganz ruhig ist. In der Gui steht dann unten in blauer Schrift: COM port open successfully, please connect ZYG-BMGC!
      Nun Betriebsspannung an das Gimbal anlegen und immer schön ruhig halten. Dann sollte es korrekt mit der Gui verbunden sein

      in dem markierten Bereich des Screenshots, kannst du dann die Grundstellung der Kamera und Winkelbegrenzungen für Pan und Tilt einstellen.
      Was oberhalb der roten Markierung steht, lass erstmal die Finger weg. Das sind die Abstimmungen für die PID-Regler. Was unterhalb der Markierung ist, kannst du eigentlich auch mal alles so übernehmen. Dann sollte es eigentlich funzen.
      Bilder
      • GUI.JPG

        112,19 kB, 890×654, 84 mal angesehen
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • Hallo,
      vielen Dank für die ausführliche Erklärung.
      Ich habe alles so abgearbeitet wie erklärt.

      Es hat mich viele Neustarts gekostet und sogar einen Bluescreen.

      Irgendwann war ich dann Connected. Die einzige Einstellung die ich geändert habe war "Angle Limit Max von 90 auf 45. Ich habe aber kein "Write Settings to Flash" angeklickt und die Einstellung wurde übernommen.
      Seitdem versucht das Gimbal die Kamera nach hinten zu stellen und macht den Breakdancer. Der ROLL der davor noch stimmte, stimmt auch nicht mehr, hängt jetzt in einem 45Grad Winkel schräg darum. Obwohl ich dort nichts verstellt habe. Über die Software kann ich nichts mehr Rückgängig machen!

      Die Kabel der Motoren habe ich auch schon von der Platine abgezocken und anschliesend Strom drauf gegeben, da ich dachte es Resetet sich, war aber auch nichts!

      Tja, mir fällt nichts mehr ein.

      Viele Grüße
      Gerd
    • So, habe es wenigstens jetzt geschafft über "Calibrate Sensors" den ROLL-Motor fast wieder in die Horizontale zu kriegen.
      Habe das Gimbal mit CD-Hüllen unterbaut das es Horizontal stand, die Kamera unter den Copter schauen lassen und dann den Calibrate Button gedrückt und ins Flash gespeichert.

      Was mich dabei wundert ist, beim ROLL hat es geklappt, beim TILT steht die Kamera wieder Senkrecht nach unten!!!

      Genervt bei dem 2-Stündigen Marathon hat auch, das die Software sich dauernd aufhängt oder der USB-Stick nicht erkannt wird und dadurch der Rechner nicht mehr einfach per Neustart, sondern am Netzschalter ausgeschaltet werden muss. Das ist doof und kostet ohne Ende Zeit.

      Laufen tut das Gimbal trotzdem noch nicht so wie es soll. Ich habe es jetzt erstmal wieder vom Copter montiert und muss mir Gedanken machen wie es weiter geht.
      Letzendlich ist noch nicht mal die Hürde genommen das Ding an die Naza-M V2 anzuschliesen. Da graut es mir jetzt schon.

      Schaut Euch mal die Bilder an:





      Man sieht auch beim Screenshot, die Kamera steht nach oben. Ist aber nach dem Calibrieren wieder unten!?

      Viele Grüße
      Gerd

      PS: Hat jemand eine "günstige" Alternative zu dem Turnigy 2-Achs Gimbal, der auch funktioniert?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mrgfink ()

    • Das sind die normalen Kalibrierungsarbeiten, die du mit jedem Gimbal hast. Ein anderes Gimbal wird dich da nicht weiterbringen und du wirst die selben Probleme haben. Kannst mir gerne das Gimbal schicken und ich stelle es dir ein und schicke es zurück.

      Probier aber mal die Werte im Angel Tilt zu verändern. Da gibt es einen Min-Wert und einen Max-Wert. Der komplette Kreis hat 360°. Hier kannst du den Ausschnitt einstellen, in dem die kamera agieren soll. Also letztendlich stellst du da nicht nur den Weg ein sondern auch die Ausgangsposition. Spiel ein bisschen mit den Werten und du siehst was passiert.

      Wahrscheinlich wirst du auch die IMU komplett kalibrieren müssen. Denn im original ist das Gimbal ja für die Gopro gedacht und da wäre diese Grund-Position vollkommen richtig. Die Möbius liegt ja in der Halterung und die Gopro ist um 90° gedreht in der Halterung.
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von chuti ()

    • Ja das kann natürlich einiges erklären.
      Ich bin normalerweise nicht der "Techniktrottel" aber was ich heute bei den Einstellarbeiten erlebte, darauf ist mir nichts mehr logisches eingefallen!
      Der verliert ja seine Werte wie er Lust hat. Legt den Rechner lahm und macht was er will...! So kam es mir vor. ;)

      Den Angel Tilt habe ich ja verändert. Habe nichts in den Flasspeicher geschrieben, trotzdem ist nach dem nächsten mal einschalten des Gimbals alles nur noch auf Breakdance gewesen. Das kann ich mir nicht erklären. Habe dann mit Tricks (im letzten Post beschrieben) das Gimbal einigermaßen wieder ins Lot bekommen, nur die Kamera hängt runter.

      Vielen Dank für das Angebot! Gerne schicke ich Dir den Gimbal zu. Die Versandkosten Hin- und Zurück übernehme selbstverständlich ich. Du musst mir nur sagen was Du für Deine Arbeit möchtest.
      Können wir alles über PayPal abrechnen.

      Viele Grüße
      Gerd

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mrgfink ()