Servo-Gimbal Pixhawk

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Servo-Gimbal Pixhawk

      Hallo,

      ich habe einen merkwürdigen Fehler bemerkt.
      Meinem Hexa habe ich ein 2-Achs-Gimbal verpasst. Die Nickachse möchte ich zusätzlich über die Funke verstellen können. Es hat am Mittwoch auf dem Acker alles wunderbar geklappt. (dort war er über Funk mit dem Laptop verbunden - Abends hatte ich ihn per USB-Kabel an meinem Desktop-PC angeschlossen, um die Logs runterzuladen und ein paar Einstellungen zu optimieren)
      Heute jedoch, als ich alles testen wollte ging fast gar nichts mehr - obwohl ich ganz sicher nicht an den Gimbaleinstellungen rumgespielt habe. Die Achsen waren auf einmal auf Reverse und die Nickachse lässt sich fast gar nicht über die Funke ansteuern. Fast - weil sie sich steuern lässt aber wie in Superzeitlupe. Ich drehe den Poti also auf Anschlag in eine Richtung und der Servo macht Minischritte in die entsprechende Richtung.
      Komischerweise funktioniert der Lageausgleich wunderbar, nachdem ich über den Laptop alles neu eingestellt habe.
      Hat jemand schon einmal ähnliche Erfahrungen gemacht? Oder, besser noch, einen Tipp für mich wie ich diesen Fehler beheben kann? Ich würde mich sehr freuen - ich würde nämlich sehr gern über ein, vor kurzem entdecktes Sonnenblumenfeld fliegen & ein paar Bilder machen bevor sie abgeblüht sind)
      Besten Dank schonmal vorab und euch ein schönes Wochenende

      Viele Grüße
    • Ok. Dann schliesse jetzt mal den Tilt direkt an einen Kanal vom Empfänger an. Wenn er dann genauso zickt, weißt du, daß der Fehler in der Gimbalelektronik steckt. Wenn es da ganz normal reagiert, müssen wir mal weiterforschen. Aber mach mal erst den Test, eh daß wir die ganze Programmierung vom Pixi auseinandernehmen.
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • Ja ok. Machen wir morgen weiter. Noch kurz eine Frage. Welches Gimbal ist es? Du hast ins Thema geschrieben, daß es ein Servogimbal ist. Ist das so oder ist es ein brushless Gimbal?
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • Ok. Dann gehen wir mal alles Stück für Stück durch. Das Gimbal sollte vorzugsweise natürlich nur die Signalpins und der Minus an Aux1 und Aux2 angeschlossen werden. Tilt an Aux1 und Roll an Aux2.
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • ok, dann habe ich dort sicher schon meinen fehler.
      ich habe die Servostecker wie sie sind angesteckt. Also beide komplett mit + - S an Aux1 und Aux2.
      Wenn das nicht so sein soll, wo bekommen denn die Servos den Strom her? Bitte entschuldige wenn ich so blöd frage aber ich dachte immer sie brauchen einen + und einen - Anschluss.
    • Die musst du dann über einen eigenen BEC versorgen. Wenn du den Plus auch noch vom Pixi holst, schafft der das nicht. Die Stromversorgung vom Pixi ist nur für den FC ausgelegt. Genau da habe ich auch den Fehler vermutet. Wenn deine ESCs einen BEC mit drin haben, kannst du die dafür verwenden. Brauchst du einen Schaltplan?
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • Man kann den Pixhawk mit einer Backup-Stromversorgung ausstatten. Das ist dann eine Redundanz. Aber ich würde solche Stromfresser niemals über den Pixhawk mit Strom versorgen. Ich habe mein Landegestell auch über einen extra BEC laufen. Der Pixi ist nur ausgelegt sich selber und allenfalls noch den Empfänger mit Strom zu versorgen. Hängst du das Gimbal dann nur an den Empfänger und dieser wird über den Pixi versorgt, kann das dann auch schon Probleme geben.
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB
    • Versuch dann mal ein Log zu generieren und schau dir im Log dann mal die Spannung vom Pixi an. Das ist der Parameter VCC. Der Parameter sollte auf keinen Fall und zu keiner Zeit unter 5 Volt sinken. Kannst dir auch über den Missionplanner den Wert direkt ansehen, während der Pixi und das Gimbal läuft.
      lg Chuti
      Lädst du noch oder fliegst du schon? Revolectrix Powerlab 8V2.

      DJI F550 mit Naza V2 mit GPS, T650-Quad mit Pixhawk GPS und Datalink, Spektrum DX7s, Taranis X9D, 4s 5000, 4s 5800, 4s 12000, 4s 15000, copterlight.de Inventor of CIPBB

      The post was edited 1 time, last by chuti ().